Sunday, February 24, 2019

Your dev environment is running NodeJS version v10.15.1 which does not meet the requirements for running this tool.

Problem

“Your dev environment is running NodeJS version v10.15.1 which does not meet the requirements for running this tool. This tool requires a version of NodeJS that matches >=8.9.4 <9.0.0”

when I try to do a gulp serve during my SPFx extension development.

Solution

Please follow the below url and additionally you may need to run

npm rebuild node-sass

as well.

https://o365insights.com/downgrade-npm-for-spfx-1.7.0/